CVE-2020-24742
High
Description
An issue has been fixed in Qt versions 5.14.0 where QPluginLoader attempts to load plugins relative to the working directory, allowing attackers to execute arbitrary code via crafted files.
SeverityHigh
CVSS7.8
Exploit probability—
ProductQt
PublishedAug 9, 2021
First seenAug 9, 2021
How to fix
Update
- qt qt5.12.7 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| qt qt | 5.6.0 ≤ v < 5.12.7, 5.13.0 ≤ v ≤ 5.13.2 | 5.12.7 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.