CVE-2020-25628
Medium
Description
The filter in the tag manager required extra sanitizing to prevent a reflected XSS risk. This affects 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. Fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.
SeverityMedium
CVSS6.1
Exploit probability—
Product
Moodle
PublishedDec 8, 2020
First seenDec 8, 2020
Weakness typeCWE-79Cross-site scripting (XSS)
How to fix
Update
- moodle moodle3.5.14, 3.7.8, 3.8.5, 3.9.2 or later
- moodle/moodle3.9.2, 3.8.5, 3.7.8, 3.5.14 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| moodle moodle | 3.5.0 ≤ v < 3.5.14, 3.7.0 ≤ v < 3.7.8, 3.8.0 ≤ v < 3.8.5, 3.9.0 ≤ v < 3.9.2 | 3.5.14, 3.7.8, 3.8.5, 3.9.2 |
| moodle/moodlePackagist | 3.9.0 ≤ v < 3.9.2, 3.8.0 ≤ v < 3.8.5, 3.7.0 ≤ v < 3.7.8, 3.5 ≤ v < 3.5.14 | 3.9.2, 3.8.5, 3.7.8, 3.5.14 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.