CVE-2020-25700

Medium

Description

In moodle, some database module web services allowed students to add entries within groups they did not belong to. Versions affected: 3.9 to 3.9.2, 3.8 to 3.8.5, 3.7 to 3.7.8, 3.5 to 3.5.14 and earlier unsupported versions. This is fixed in moodle 3.8.6, 3.7.9, 3.5.15, and 3.10.

SeverityMedium
CVSS6.5
Exploit probability72. percentile1.3%
ProductMoodle
PublishedNov 19, 2020
First seenNov 19, 2020
Weakness typeCWE-89SQL injection

How to fix

Affected products

ProductAffected versionsFixed in
moodle moodle3.5.0 ≤ v ≤ 3.5.14, 3.7.0 ≤ v ≤ 3.7.8, 3.8.0 ≤ v ≤ 3.8.5, 3.9.0 ≤ v ≤ 3.9.2—
fedoraproject fedora32, 33—
moodle/moodlePackagist3.9.0 ≤ v < 3.9.3, 3.8.0 ≤ v < 3.8.6, 3.7.0 ≤ v < 3.7.9, 3.5.0 ≤ v < 3.5.153.9.3, 3.8.6, 3.7.9, 3.5.15

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2020-25700 · Moodle · Dark Radar