CVE-2020-25717

High

Description

A flaw was found in the way Samba maps domain users to local users. An authenticated attacker could use this flaw to cause possible privilege escalation.

SeverityHigh
CVSS8.1
Exploit probability—
ProductSamba
PublishedFeb 18, 2022
First seenFeb 18, 2022

How to fix

Update
  • samba samba4.13.14, 4.14.10, 4.15.2 or later

Affected products

ProductAffected versionsFixed in
samba samba3.0.0 ≤ v < 4.13.14, 4.14.0 ≤ v < 4.14.10, 4.15.0 ≤ v < 4.15.24.13.14, 4.14.10, 4.15.2
debian debian_linux9.0, 10.0—
fedoraproject fedora33, 34, 35—
redhat codeready_linux_builderNo range specified—
redhat gluster_storage3.0, 3.5—
redhat openstack13, 16.1, 16.2—
redhat virtualization4.0—
redhat virtualization_host4.0—
redhat enterprise_linux7.0, 8.0—
redhat enterprise_linux_desktop7.0—
redhat enterprise_linux_eus8.2, 8.4—
redhat enterprise_linux_for_ibm_z_systems7.0, 8.0—
redhat enterprise_linux_for_ibm_z_systems_eus8.2, 8.4—
redhat enterprise_linux_for_power_big_endian7.0—
redhat enterprise_linux_for_power_little_endian7.0, 8.0—
redhat enterprise_linux_for_power_little_endian_eus8.2, 8.4—
redhat enterprise_linux_for_scientific_computing7.0—
redhat enterprise_linux_resilient_storage7.0—
redhat enterprise_linux_server7.0—
redhat enterprise_linux_server_aus8.2, 8.4—
redhat enterprise_linux_server_tus8.4—
redhat enterprise_linux_server_update_services_for_sap_solutions8.2, 8.4—
redhat enterprise_linux_tus8.2—
redhat enterprise_linux_workstation7.0—
canonical ubuntu_linux18.04, 20.04, 21.04, 21.10—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.