CVE-2020-26216

High

Description

TYPO3 Fluid before versions 2.0.8, 2.1.7, 2.2.4, 2.3.7, 2.4.4, 2.5.11 and 2.6.10 is vulnerable to Cross-Site Scripting. Three XSS vulnerabilities have been detected in Fluid: 1. TagBasedViewHelper allowed XSS through maliciously crafted additionalAttributes arrays by creating keys with attribute-closing quotes followed by HTML. When rendering such attributes, TagBuilder would not escape the keys. 2. ViewHelpers which used the CompileWithContentArgumentAndRenderStatic trait, and which declared escapeOutput = false, would receive the content argument in unescaped format. 3. Subclasses of AbstractConditionViewHelper would receive the then and else arguments in unescaped format. Update to versions 2.0.8, 2.1.7, 2.2.4, 2.3.7, 2.4.4, 2.5.11 or 2.6.10 of this typo3fluid/fluid package that fix the problem described. More details are available in the linked advisory.

SeverityHigh
CVSS8.0
Exploit probability—
ProductTypo3 Fluid
PublishedNov 17, 2020
First seenNov 17, 2020

How to fix

Update
  • typo3 fluid2.0.8, 2.1.7, 2.2.4, 2.3.7, 2.4.4, 2.5.11, 2.6.10 or later
  • typo3fluid/fluid2.0.8, 2.1.7, 2.2.4, 2.3.7, 2.4.4, 2.5.11, 2.6.10 or later

Affected products

ProductAffected versionsFixed in
typo3 fluidv < 2.0.8, 2.1.0 ≤ v < 2.1.7, 2.2.0 ≤ v < 2.2.4, 2.3.0 ≤ v < 2.3.7, 2.4.0 ≤ v < 2.4.4, 2.5.0 ≤ v < 2.5.11, 2.6.0 ≤ v < 2.6.102.0.8, 2.1.7, 2.2.4, 2.3.7, 2.4.4, 2.5.11, 2.6.10
typo3fluid/fluidPackagist2.0.0 ≤ v < 2.0.8, 2.1.0 ≤ v < 2.1.7, 2.2.0 ≤ v < 2.2.4, 2.3.0 ≤ v < 2.3.7, 2.4.0 ≤ v < 2.4.4, 2.5.0 ≤ v < 2.5.11, 2.6.0 ≤ v < 2.6.102.0.8, 2.1.7, 2.2.4, 2.3.7, 2.4.4, 2.5.11, 2.6.10

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.