CVE-2020-26223

High

Description

Spree is a complete open source e-commerce solution built with Ruby on Rails. In Spree from version 3.7 and before versions 3.7.13, 4.0.5, and 4.1.12, there is an authorization bypass vulnerability. The perpetrator could query the API v2 Order Status endpoint with an empty string passed as an Order token. This is patched in versions 3.7.11, 4.0.4, or 4.1.11 depending on your used Spree version. Users of Spree < 3.7 are not affected.

SeverityHigh
CVSS7.7
Exploit probability—
ProductSpree
PublishedNov 13, 2020
First seenNov 13, 2020

How to fix

Update
  • spreecommerce spree3.7.13, 4.0.5, 4.1.12 or later

Affected products

ProductAffected versionsFixed in
spreecommerce spree3.7.0 ≤ v < 3.7.13, 4.0.0 ≤ v < 4.0.5, 4.1.0 ≤ v < 4.1.123.7.13, 4.0.5, 4.1.12

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2020-26223 · Spree · Dark Radar