CVE-2020-26255
Description
Kirby is a CMS. In Kirby CMS (getkirby/cms) before version 3.4.5, and Kirby Panel before version 2.5.14 , an editor with full access to the Kirby Panel can upload a PHP .phar file and execute it on the server. This vulnerability is critical if you might have potential attackers in your group of authenticated Panel users, as they can gain access to the server with such a Phar file. Visitors without Panel access *cannot* use this attack vector. The problem has been patched in Kirby 2.5.14 and Kirby 3.4.5. Please update to one of these or a later version to fix the vulnerability. Note: Kirby 2 reaches end of life on December 31, 2020. We therefore recommend to upgrade your Kirby 2 sites to Kirby 3. If you cannot upgrade, we still recommend to update to Kirby 2.5.14.
How to fix
- getkirby kirby3.4.5 or later
- getkirby panel2.5.14 or later
- getkirby/panel2.5.14 or later
- getkirby/cms3.4.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| getkirby kirby | v < 3.4.5 | 3.4.5 |
| getkirby panel | v < 2.5.14 | 2.5.14 |
| getkirby/panelPackagist | v < 2.5.14 | 2.5.14 |
| getkirby/cmsPackagist | 3.0.0 ≤ v < 3.4.5 | 3.4.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.