CVE-2020-26266
Medium
Description
In affected versions of TensorFlow under certain cases a saved model can trigger use of uninitialized values during code execution. This is caused by having tensor buffers be filled with the default value of the type but forgetting to default initialize the quantized floating point types in Eigen. This is fixed in versions 1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2, and 2.4.0.
SeverityMedium
CVSS4.4
Exploit probability—
Product
Google Tensorflow
PublishedDec 10, 2020
First seenDec 10, 2020
Weakness typeCWE-908CWE-908
How to fix
Update
- google tensorflow1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2 or later
- tensorflow1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2 or later
- tensorflow-cpu1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2 or later
- tensorflow-gpu1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| google tensorflow | v < 1.15.5, 2.0.0 ≤ v < 2.0.4, 2.1.0 ≤ v < 2.1.3, 2.2.0 ≤ v < 2.2.2, 2.3.0 ≤ v < 2.3.2 | 1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2 |
| tensorflowPyPI | v < 1.15.5, 2.0.0 ≤ v < 2.0.4, 2.1.0 ≤ v < 2.1.3, 2.2.0 ≤ v < 2.2.2, 2.3.0 ≤ v < 2.3.2 | 1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2 |
| tensorflow-cpuPyPI | v < 1.15.5, 2.0.0 ≤ v < 2.0.4, 2.1.0 ≤ v < 2.1.3, 2.2.0 ≤ v < 2.2.2, 2.3.0 ≤ v < 2.3.2 | 1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2 |
| tensorflow-gpuPyPI | v < 1.15.5, 2.0.0 ≤ v < 2.0.4, 2.1.0 ≤ v < 2.1.3, 2.2.0 ≤ v < 2.2.2, 2.3.0 ≤ v < 2.3.2 | 1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.