CVE-2020-26268

Medium

Description

In affected versions of TensorFlow the tf.raw_ops.ImmutableConst operation returns a constant tensor created from a memory mapped file which is assumed immutable. However, if the type of the tensor is not an integral type, the operation crashes the Python interpreter as it tries to write to the memory area. If the file is too small, TensorFlow properly returns an error as the memory area has fewer bytes than what is needed for the tensor it creates. However, as soon as there are enough bytes, the above snippet causes a segmentation fault. This is because the allocator used to return the buffer data is not marked as returning an opaque handle since the needed virtual method is not overridden. This is fixed in versions 1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2, and 2.4.0.

SeverityMedium
CVSS4.4
Exploit probability—
ProductGoogle Tensorflow
PublishedDec 10, 2020
First seenDec 10, 2020
Weakness typeCWE-471CWE-471

How to fix

Update
  • google tensorflow1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2 or later
  • tensorflow1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2 or later
  • tensorflow-cpu1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2 or later
  • tensorflow-gpu1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2 or later

Affected products

ProductAffected versionsFixed in
google tensorflowv < 1.15.5, 2.0.0 ≤ v < 2.0.4, 2.1.0 ≤ v < 2.1.3, 2.2.0 ≤ v < 2.2.2, 2.3.0 ≤ v < 2.3.21.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2
tensorflowPyPIv < 1.15.5, 2.0.0 ≤ v < 2.0.4, 2.1.0 ≤ v < 2.1.3, 2.2.0 ≤ v < 2.2.2, 2.3.0 ≤ v < 2.3.21.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2
tensorflow-cpuPyPIv < 1.15.5, 2.0.0 ≤ v < 2.0.4, 2.1.0 ≤ v < 2.1.3, 2.2.0 ≤ v < 2.2.2, 2.3.0 ≤ v < 2.3.21.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2
tensorflow-gpuPyPIv < 1.15.5, 2.0.0 ≤ v < 2.0.4, 2.1.0 ≤ v < 2.1.3, 2.2.0 ≤ v < 2.2.2, 2.3.0 ≤ v < 2.3.21.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.