CVE-2020-26270
Medium
Description
In affected versions of TensorFlow running an LSTM/GRU model where the LSTM/GRU layer receives an input with zero-length results in a CHECK failure when using the CUDA backend. This can result in a query-of-death vulnerability, via denial of service, if users can control the input to the layer. This is fixed in versions 1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2, and 2.4.0.
SeverityMedium
CVSS4.4
Exploit probability—
Product
Google Tensorflow
PublishedDec 10, 2020
First seenDec 10, 2020
Weakness typeCWE-20Improper input validation
How to fix
Update
- google tensorflow1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2 or later
- tensorflow1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2 or later
- tensorflow-cpu1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2 or later
- tensorflow-gpu1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| google tensorflow | v < 1.15.5, 2.0.0 ≤ v < 2.0.4, 2.1.0 ≤ v < 2.1.3, 2.2.0 ≤ v < 2.2.2, 2.3.0 ≤ v < 2.3.2 | 1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2 |
| tensorflowPyPI | v < 1.15.5, 2.0.0 ≤ v < 2.0.4, 2.1.0 ≤ v < 2.1.3, 2.2.0 ≤ v < 2.2.2, 2.3.0 ≤ v < 2.3.2 | 1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2 |
| tensorflow-cpuPyPI | v < 1.15.5, 2.0.0 ≤ v < 2.0.4, 2.1.0 ≤ v < 2.1.3, 2.2.0 ≤ v < 2.2.2, 2.3.0 ≤ v < 2.3.2 | 1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2 |
| tensorflow-gpuPyPI | v < 1.15.5, 2.0.0 ≤ v < 2.0.4, 2.1.0 ≤ v < 2.1.3, 2.2.0 ≤ v < 2.2.2, 2.3.0 ≤ v < 2.3.2 | 1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.