CVE-2020-4031
Low
Description
In FreeRDP before version 2.1.2, there is a use-after-free in gdi_SelectObject. All FreeRDP clients using compatibility mode with /relax-order-checks are affected. This is fixed in version 2.1.2.
SeverityLow
CVSS3.5
Exploit probability—
Product
Freerdp
PublishedJun 22, 2020
First seenJun 22, 2020
Weakness typeCWE-416Use after free
How to fix
Update
- freerdp freerdp2.1.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| freerdp freerdp | v < 2.1.2 | 2.1.2 |
| fedoraproject fedora | 31, 32 | — |
| opensuse leap | 15.1 | — |
| canonical ubuntu_linux | 18.04, 20.04 | — |
| debian debian_linux | 10.0 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.