CVE-2020-4038
Description
GraphQL Playground (graphql-playground-html NPM package) before version 1.6.22 have a severe XSS Reflection attack vulnerability. All unsanitized user input passed into renderPlaygroundPage() method could trigger this vulnerability. This has been patched in graphql-playground-html version 1.6.22. Note that some of the associated dependent middleware packages are also affected including but not limited to graphql-playground-middleware-express before version 1.7.16, graphql-playground-middleware-koa before version 1.6.15, graphql-playground-middleware-lambda before version 1.7.17, and graphql-playground-middleware-hapi before 1.6.13.
How to fix
- prisma graphql-playground-html1.6.22 or later
- prisma graphql-playground-middleware-express1.7.16 or later
- prisma graphql-playground-middleware-hapi1.6.13 or later
- prisma graphql-playground-middleware-koa1.6.15 or later
- prisma graphql-playground-middleware-lambda1.7.17 or later
- graphql-playground-html1.6.22 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| prisma graphql-playground-html | v < 1.6.22 | 1.6.22 |
| prisma graphql-playground-middleware-express | v < 1.7.16 | 1.7.16 |
| prisma graphql-playground-middleware-hapi | v < 1.6.13 | 1.6.13 |
| prisma graphql-playground-middleware-koa | v < 1.6.15 | 1.6.15 |
| prisma graphql-playground-middleware-lambda | v < 1.7.17 | 1.7.17 |
| graphql-playground-htmlnpm | v < 1.6.22 | 1.6.22 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.