CVE-2020-4049

Low

Description

In affected versions of WordPress, when uploading themes, the name of the theme folder can be crafted in a way that could lead to JavaScript execution in /wp-admin on the themes page. This does require an admin to upload the theme, and is low severity self-XSS. This has been patched in version 5.4.2, along with all the previously affected versions via a minor release (5.3.4, 5.2.7, 5.1.6, 5.0.10, 4.9.15, 4.8.14, 4.7.18, 4.6.19, 4.5.22, 4.4.23, 4.3.24, 4.2.28, 4.1.31, 4.0.31, 3.9.32, 3.8.34, 3.7.34).

SeverityLow
CVSS2.4
Exploit probability—
ProductWordpress
PublishedJun 12, 2020
First seenJun 12, 2020
Weakness typeCWE-80CWE-80

How to fix

Update
  • wordpress wordpress3.7.34, 3.8.34, 3.9.32, 4.0.31, 4.1.31, 4.2.28, 4.3.24, 4.4.23, 4.5.22, 4.6.19, 4.7.18, 4.8.14, 4.9.15, 5.0.10, 5.1.6, 5.2.7, 5.3.4, 5.4.2 or later

Affected products

ProductAffected versionsFixed in
wordpress wordpress3.7 ≤ v < 3.7.34, 3.8 ≤ v < 3.8.34, 3.9 ≤ v < 3.9.32, 4.0 ≤ v < 4.0.31, 4.1 ≤ v < 4.1.31, 4.2 ≤ v < 4.2.28, 4.3 ≤ v < 4.3.24, 4.4 ≤ v < 4.4.23, 4.5 ≤ v < 4.5.22, 4.6 ≤ v < 4.6.19, 4.7 ≤ v < 4.7.18, 4.8 ≤ v < 4.8.14, 4.9 ≤ v < 4.9.15, 5.0 ≤ v < 5.0.10, 5.1 ≤ v < 5.1.6, 5.2 ≤ v < 5.2.7, 5.3.0 ≤ v < 5.3.4, 5.4 ≤ v < 5.4.23.7.34, 3.8.34, 3.9.32, 4.0.31, 4.1.31, 4.2.28, 4.3.24, 4.4.23, 4.5.22, 4.6.19, 4.7.18, 4.8.14, 4.9.15, 5.0.10, 5.1.6, 5.2.7, 5.3.4, 5.4.2
fedoraproject fedora31, 32—
debian debian_linux8.0, 9.0, 10.0—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.