CVE-2020-5210

Medium

Description

In NetHack before 3.6.5, an invalid argument to the -w command line option can cause a buffer overflow resulting in a crash or remote code execution/privilege escalation. This vulnerability affects systems that have NetHack installed suid/sgid and shared systems that allow users to influence command line options. Users should upgrade to NetHack 3.6.5.

SeverityMedium
CVSS5.0
Exploit probability—
ProductNethack
PublishedJan 28, 2020
First seenJan 28, 2020
Weakness typeCWE-120CWE-120

How to fix

Update
  • nethack nethack3.6.5 or later

Affected products

ProductAffected versionsFixed in
nethack nethackv < 3.6.53.6.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.