CVE-2020-5237
Description
Multiple relative path traversal vulnerabilities in the oneup/uploader-bundle before 1.9.3 and 2.1.5 allow remote attackers to upload, copy, and modify files on the filesystem (potentially leading to arbitrary code execution) via the (1) filename parameter to BlueimpController.php; the (2) dzchunkindex, (3) dzuuid, or (4) filename parameter to DropzoneController.php; the (5) qqpartindex, (6) qqfilename, or (7) qquuid parameter to FineUploaderController.php; the (8) x-file-id or (9) x-file-name parameter to MooUploadController.php; or the (10) name or (11) chunk parameter to PluploadController.php. This is fixed in versions 1.9.3 and 2.1.5.
How to fix
- oneup/uploader-bundle2.1.5, 1.9.3 or later
- 1up oneupuploaderbundle1.9.3, 2.1.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| oneup/uploader-bundlePackagist | 2.0.0 ≤ v < 2.1.5, 1.0.0 ≤ v < 1.9.3 | 2.1.5, 1.9.3 |
| 1up oneupuploaderbundle | v < 1.9.3, 1.9.4 ≤ v < 2.1.5 | 1.9.3, 2.1.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.