CVE-2020-5245
High
Description
Dropwizard-Validation before 1.3.19, and 2.0.2 may allow arbitrary code execution on the host system, with the privileges of the Dropwizard service account, by injecting arbitrary Java Expression Language expressions when using the self-validating feature. The issue has been fixed in dropwizard-validation 1.3.19 and 2.0.2.
SeverityHigh
CVSS7.9
Exploit probability—
Product
Dropwizard Validation
PublishedFeb 24, 2020
First seenFeb 24, 2020
Weakness typeCWE-74Injection
How to fix
Update
- dropwizard dropwizard_validation1.3.19, 2.0.2 or later
- oracle blockchain_platform21.1.2 or later
- io.dropwizard:dropwizard-validation1.3.19, 2.0.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| dropwizard dropwizard_validation | v < 1.3.19, 2.0.0 ≤ v < 2.0.2 | 1.3.19, 2.0.2 |
| oracle blockchain_platform | v < 21.1.2 | 21.1.2 |
| io.dropwizard:dropwizard-validationMaven | 1.3.0-rc1 ≤ v < 1.3.19, 2.0.0 ≤ v < 2.0.2 | 1.3.19, 2.0.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.