CVE-2020-5256
Description
BookStack before version 0.25.5 has a vulnerability where a user could upload PHP files through image upload functions, which would allow them to execute code on the host system remotely. They would then have the permissions of the PHP process. This most impacts scenarios where non-trusted users are given permission to upload images in any area of the application. The issue was addressed in a series of patches in versions 0.25.3, 0.25.4 and 0.25.5. Users should upgrade to at least v0.25.5 to avoid this vulnerability.
How to fix
- bookstackapp bookstack0.25.3 or later
- ssddanbrown/bookstack0.25.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| bookstackapp bookstack | v < 0.25.3 | 0.25.3 |
| ssddanbrown/bookstackPackagist | v < 0.25.5 | 0.25.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.