CVE-2020-5260

Critical

Description

Affected versions of Git have a vulnerability whereby Git can be tricked into sending private credentials to a host controlled by an attacker. Git uses external "credential helper" programs to store and retrieve passwords or other credentials from secure storage provided by the operating system. Specially-crafted URLs that contain an encoded newline can inject unintended values into the credential helper protocol stream, causing the credential helper to retrieve the password for one server (e.g., good.example.com) for an HTTP request being made to another server (e.g., evil.example.com), resulting in credentials for the former being sent to the latter. There are no restrictions on the relationship between the two, meaning that an attacker can craft a URL that will present stored credentials for any host to a host of their choosing. The vulnerability can be triggered by feeding a malicious URL to git clone. However, the affected URLs look rather suspicious; the likely vector would be through systems which automatically clone URLs not visible to the user, such as Git submodules, or package systems built around Git. The problem has been patched in the versions published on April 14th, 2020, going back to v2.17.x. Anyone wishing to backport the change further can do so by applying commit 9a6bbee (the full release includes extra checks for git fsck, but that commit is sufficient to protect clients against the vulnerability). The patched versions are: 2.17.4, 2.18.3, 2.19.4, 2.20.3, 2.21.2, 2.22.3, 2.23.2, 2.24.2, 2.25.3, 2.26.1.

SeverityCritical
CVSS9.3
Exploit probability—
ProductGit
PublishedApr 14, 2020
First seenApr 14, 2020

How to fix

Affected products

ProductAffected versionsFixed in
git gitv < 2.17.4, 2.22.0 ≤ v < 2.22.32.17.4, 2.22.3
git-scm git2.18.0 ≤ v < 2.18.3, 2.19.0 ≤ v < 2.19.4, 2.20.0 ≤ v < 2.20.3, 2.21.0 ≤ v < 2.21.2, 2.23.0 ≤ v < 2.23.2, 2.24.0 ≤ v < 2.24.2, 2.25.0 ≤ v < 2.25.3, 2.26.0 ≤ v < 2.26.12.18.3, 2.19.4, 2.20.3, 2.21.2, 2.23.2, 2.24.2, 2.25.3, 2.26.1
canonical ubuntu_linux16.04, 18.04, 19.10—
debian debian_linux8.0, 9.0, 10.0—
fedoraproject fedora30, 31, 32—
opensuse leap15.1—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.