CVE-2020-7956
Critical
Description
HashiCorp Nomad and Nomad Enterprise up to 0.10.2 incorrectly validated role/region associated with TLS certificates used for mTLS RPC, and were susceptible to privilege escalation. Fixed in 0.10.3.
SeverityCritical
CVSS9.8
Exploit probability—
ProductHashicorp Nomad
PublishedJan 31, 2020
First seenJan 31, 2020
How to fix
Update
- hashicorp nomad0.10.3 or later
- github.com/hashicorp/nomad0.10.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| hashicorp nomad | v < 0.10.3 | 0.10.3 |
| github.com/hashicorp/nomadGo | v < 0.10.3 | 0.10.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.