CVE-2020-8203
High
Description
Prototype pollution attack when using _.zipObjectDeep in lodash before 4.17.20.
SeverityHigh
CVSS7.4
Exploit probability—
Product
Lodash
PublishedJul 15, 2020
First seenJul 15, 2020
Weakness typeCWE-770Allocation of resources without limits
How to fix
Update
- lodash lodash4.17.20 or later
- oracle blockchain_platform21.1.2 or later
- lodash4.17.19 or later
- lodash-es4.17.20 or later
- lodash-rails4.17.19 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| lodash lodash | v < 4.17.20 | 4.17.20 |
| oracle banking_corporate_lending_process_management | 14.2.0, 14.3.0, 14.5.0 | — |
| oracle banking_credit_facilities_process_management | 14.2.0, 14.3.0, 14.5.0 | — |
| oracle banking_extensibility_workbench | 14.2.0, 14.3.0, 14.5.0 | — |
| oracle banking_liquidity_management | 14.2.0, 14.3.0, 14.5.0 | — |
| oracle banking_supply_chain_finance | 14.2.0, 14.3.0, 14.5.0 | — |
| oracle banking_trade_finance_process_management | 14.2.0, 14.3.0, 14.5.0 | — |
| oracle banking_virtual_account_management | 14.2.0, 14.3.0, 14.5.0 | — |
| oracle blockchain_platform | v < 21.1.2 | 21.1.2 |
| oracle communications_billing_and_revenue_management | 7.5.0.23.0, 12.0.0.3.0 | — |
| oracle communications_cloud_native_core_policy | 1.11.0 | — |
| oracle communications_session_border_controller | 8.4, 9.0, cz8.4 | — |
| oracle communications_session_router | cz8.4 | — |
| oracle communications_subscriber-aware_load_balancer | cz8.3, cz8.4 | — |
| oracle enterprise_communications_broker | 3.2.0, 3.3.0, pcz3.3 | — |
| oracle jd_edwards_enterpriseone_tools | v ≤ 9.2.6.0 | — |
| oracle peoplesoft_enterprise_peopletools | 8.58, 8.59 | — |
| oracle primavera_gateway | 17.12.0 ≤ v ≤ 17.12.11, 18.8.0 ≤ v ≤ 18.8.12, 19.12.0 ≤ v ≤ 19.12.11, 20.12.0 ≤ v ≤ 20.12.7 | — |
| lodashnpm | 3.7.0 ≤ v < 4.17.19 | 4.17.19 |
| lodash-esnpm | 3.7.0 ≤ v < 4.17.20 | 4.17.20 |
| lodash.picknpm | 4.0.0 ≤ v ≤ 4.4.0 | — |
| lodash.setnpm | 3.7.0 ≤ v ≤ 4.3.2 | — |
| lodash.setwithnpm | v ≤ 4.3.2 | — |
| lodash.updatenpm | v ≤ 4.10.2 | — |
| lodash.updatewithnpm | v ≤ 4.10.2 | — |
| lodash-railsRubyGems | 3.7.0 ≤ v < 4.17.19 | 4.17.19 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.