CVE-2020-8905

Low

Description

A buffer length validation vulnerability in Asylo versions prior to 0.6.0 allows an attacker to read data they should not have access to. The 'enc_untrusted_recvfrom' function generates a return value which is deserialized by 'MessageReader', and copied into three different 'extents'. The length of the third 'extents' is controlled by the outside world, and not verified on copy, allowing the attacker to force Asylo to copy trusted memory data into an untrusted buffer of significantly small length.. We recommend updating Asylo to version 0.6.0 or later.

SeverityLow
CVSS2.8
Exploit probability—
ProductGoogle Asylo
PublishedAug 12, 2020
First seenAug 12, 2020
Weakness typeCWE-120CWE-120

How to fix

Update
  • google asylo0.6.0 or later

Affected products

ProductAffected versionsFixed in
google asylov < 0.6.00.6.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.