CVE-2020-8927
Description
A buffer overflow exists in the Brotli library versions prior to 1.0.8 where an attacker controlling the input length of a "one-shot" decompression request to a script can trigger a crash, which happens when copying over chunks of data larger than 2 GiB. It is recommended to update your Brotli library to 1.0.8 or later. If one cannot update, we recommend to use the "streaming" API as opposed to the "one-shot" API, and impose chunk size limits.
How to fix
- google brotli1.0.8 or later
- microsoft powershell7.0.9, 7.1.6, 7.2.2 or later
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MMBKACMLSRX7JJSKBTR35UOEP2WFR6QP/
- usn.ubuntu.com/4568-1/
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WW62OZEY2GHJL4JCOLJRBSRETXDHMWRK/
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/J4E265WKWKYMK2RYYSIXBEGZTDY5IQE6/
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/M4VCDOJGL6BK3HB4XRD2WETBPYX2ITF6/
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/W23CUADGMVMQQNFKHPHXVP7RPZJZNN6I/
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/356JOYTWW4BWSZ42SEFLV7NYHL3S3AEH/
- debian.org/security/2020/dsa-4801
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZXEQ3GQVELA2T4HNZG7VPMS2HDVXMJRG/
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MQLM7ABVCYJLF6JRPF3M3EBXW63GNC27/
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4TOGTZ2ZWDH662ZNFFSZVL3M5AJXV6JF/
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| google brotli | v < 1.0.8 | 1.0.8 |
| debian debian_linux | 9.0, 10.0 | — |
| fedoraproject fedora | 31, 32, 33, 34, 35, 36 | — |
| canonical ubuntu_linux | 16.04, 18.04, 20.04 | — |
| opensuse leap | 15.2 | — |
| microsoft .net | 5.0 ≤ v ≤ 5.0.14 | — |
| microsoft .net_core | 3.1 ≤ v ≤ 3.1.22 | — |
| microsoft powershell | 7.0 ≤ v < 7.0.9, 7.1 ≤ v < 7.1.6, 7.2 ≤ v < 7.2.2 | 7.0.9, 7.1.6, 7.2.2 |
| microsoft visual_studio_2019 | 16.0 ≤ v ≤ 16.11 | — |
| microsoft visual_studio_2022 | 17.0 ≤ v ≤ 17.0.7, 17.1 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.