CVE-2021-21252

Medium

Description

The jQuery Validation Plugin provides drop-in validation for your existing forms. It is published as an npm package "jquery-validation". jquery-validation before version 1.19.3 contains one or more regular expressions that are vulnerable to ReDoS (Regular Expression Denial of Service). This is fixed in 1.19.3.

SeverityMedium
CVSS5.3
Exploit probability—
ProductJqueryvalidation Jquery Validation
PublishedJan 13, 2021
First seenJan 13, 2021

How to fix

Update
  • jqueryvalidation jquery_validation1.19.3 or later
  • jquery-validation1.19.3 or later
  • jQuery.Validation1.19.3 or later

Affected products

ProductAffected versionsFixed in
jqueryvalidation jquery_validationv < 1.19.31.19.3
netapp snapcenterNo range specified—
jquery-validationnpmv < 1.19.31.19.3
jQuery.ValidationNuGetv < 1.19.31.19.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2021-21252 · Jqueryvalidation Jquery Validation · Dark Radar