CVE-2021-21281

High

Description

Contiki-NG is an open-source, cross-platform operating system for internet of things devices. A buffer overflow vulnerability exists in Contiki-NG versions prior to 4.6. After establishing a TCP socket using the tcp-socket library, it is possible for the remote end to send a packet with a data offset that is unvalidated. The problem has been patched in Contiki-NG 4.6. Users can apply the patch for this vulnerability out-of-band as a workaround.

SeverityHigh
CVSS7.0
Exploit probability—
ProductContiki-ng
PublishedJun 18, 2021
First seenJun 18, 2021
Weakness typeCWE-120CWE-120

How to fix

Update
  • contiki-ng contiki-ng4.6 or later

Affected products

ProductAffected versionsFixed in
contiki-ng contiki-ngv < 4.64.6

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.