CVE-2021-21298

Low

Description

Node-Red is a low-code programming for event-driven applications built using nodejs. Node-RED 1.2.7 and earlier has a vulnerability which allows arbitrary path traversal via the Projects API. If the Projects feature is enabled, a user with `projects.read` permission is able to access any file via the Projects API. The issue has been patched in Node-RED 1.2.8. The vulnerability applies only to the Projects feature which is not enabled by default in Node-RED. The primary workaround is not give untrusted users read access to the Node-RED editor.

SeverityLow
CVSS3.5
Exploit probability—
ProductNodered Node-red
PublishedFeb 26, 2021
First seenFeb 26, 2021

How to fix

Update
  • nodered node-red1.2.8 or later
  • @node-red/runtime1.2.8 or later

Affected products

ProductAffected versionsFixed in
nodered node-redv < 1.2.81.2.8
@node-red/runtimenpmv < 1.2.81.2.8

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.