CVE-2021-21311
Description
Adminer is an open-source database management in a single PHP file. In adminer from version 4.0.0 and before 4.7.9 there is a server-side request forgery vulnerability. Users of Adminer versions bundling all drivers (e.g. `adminer.php`) are affected. This is fixed in version 4.7.9.
How to fix
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
CISA due date: Oct 20, 2025- adminer adminer4.7.9 or later
- vrana/adminer4.7.9 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| adminer adminer | 4.0.0 ≤ v < 4.7.9 | 4.7.9 |
| debian debian_linux | 9.0 | — |
| vrana/adminerPackagist | v < 4.7.9 | 4.7.9 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.