CVE-2021-21336
Description
Products.PluggableAuthService is a pluggable Zope authentication and authorization framework. In Products.PluggableAuthService before version 2.6.0 there is an information disclosure vulnerability - everyone can list the names of roles defined in the ZODB Role Manager plugin if the site uses this plugin. The problem has been fixed in version 2.6.0. Depending on how you have installed Products.PluggableAuthService, you should change the buildout version pin to 2.6.0 and re-run the buildout, or if you used pip simply do `pip install "Products.PluggableAuthService>=2.6.0"`.
How to fix
- zope products.pluggableauthservice2.6.0 or later
- products-pluggableauthservice2.6.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| zope products.pluggableauthservice | v < 2.6.0 | 2.6.0 |
| plone plone | 4.3.0 ≤ v ≤ 4.3.20, 5.0 ≤ v ≤ 5.2.4 | — |
| products-pluggableauthservicePyPI | v < 2.6.0 | 2.6.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.