CVE-2021-21358
Medium
Description
TYPO3 is an open source PHP based web content management system. In TYPO3 before versions 10.4.14, 11.1.1 it has been discovered that the Form Designer backend module of the Form Framework is vulnerable to cross-site scripting. A valid backend user account with access to the form module is needed to exploit this vulnerability. This is fixed in versions 10.4.14, 11.1.1.
SeverityMedium
CVSS5.4
Exploit probability—
Product
Typo3
PublishedMar 23, 2021
First seenMar 23, 2021
Weakness typeCWE-79Cross-site scripting (XSS)
How to fix
Update
- typo3 typo310.4.14, 11.1.1 or later
- typo3/cms-form10.4.14, 11.1.1 or later
- typo3/cms-core10.4.14, 11.1.1 or later
- typo3/cms10.4.14, 11.1.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| typo3 typo3 | 10.2.0 ≤ v < 10.4.14, 11.0.0 ≤ v < 11.1.1 | 10.4.14, 11.1.1 |
| typo3/cms-formPackagist | 10.2.0 ≤ v < 10.4.14, 11.0.0 ≤ v < 11.1.1 | 10.4.14, 11.1.1 |
| typo3/cms-corePackagist | 10.0.0 ≤ v < 10.4.14, 11.0.0 ≤ v < 11.1.1 | 10.4.14, 11.1.1 |
| typo3/cmsPackagist | 10.0.0 ≤ v < 10.4.14, 11.0.0 ≤ v < 11.1.1 | 10.4.14, 11.1.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.