CVE-2021-21361
Medium
Description
The `com.bmuschko:gradle-vagrant-plugin` Gradle plugin contains an information disclosure vulnerability due to the logging of the system environment variables. When this Gradle plugin is executed in public CI/CD, this can lead to sensitive credentials being exposed to malicious actors. This is fixed in version 3.0.0.
SeverityMedium
CVSS5.3
Exploit probability—
ProductVagrant
PublishedMar 9, 2021
First seenMar 9, 2021
Weakness typeCWE-532CWE-532
How to fix
Update
- vagrant_project vagrant0.6, 3.0.0 or later
- com.bmuschko:gradle-vagrant-plugin3.0.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| vagrant_project vagrant | v < 0.6, 2.0 ≤ v < 3.0.0 | 0.6, 3.0.0 |
| com.bmuschko:gradle-vagrant-pluginMaven | 0.6 ≤ v < 3.0.0 | 3.0.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.