CVE-2021-21365
Description
Bootstrap Package is a theme for TYPO3. It has been discovered that rendering content in the website frontend is vulnerable to cross-site scripting. A valid backend user account is needed to exploit this vulnerability. Users of the extension, who have overwritten the affected templates with custom code must manually apply the security fix. Update to version 7.1.2, 8.0.8, 9.1.4, 10.0.10 or 11.0.3 of the Bootstrap Package that fix the problem described. Updated version are available from the TYPO3 extension manager, Packagist and at https://extensions.typo3.org/extension/download/bootstrap_package/.
How to fix
- typo3 typo37.1.2, 8.0.8, 9.0.4, 9.1.3, 10.0.10, 11.0.3 or later
- bk2k/bootstrap-package7.1.2, 8.0.8, 9.0.4, 9.1.3, 10.0.10, 11.0.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| typo3 typo3 | v < 7.1.2, 8.0.0 ≤ v < 8.0.8, 9.0.0 ≤ v < 9.0.4, 9.1.0 ≤ v < 9.1.3, 10.0.0 ≤ v < 10.0.10, 11.0.0 ≤ v < 11.0.3 | 7.1.2, 8.0.8, 9.0.4, 9.1.3, 10.0.10, 11.0.3 |
| bk2k/bootstrap-packagePackagist | 7.1.0 ≤ v < 7.1.2, 8.0.0 ≤ v < 8.0.8, 9.0.0 ≤ v < 9.0.4, 9.1.0 ≤ v < 9.1.3, 10.0.0 ≤ v < 10.0.10, 11.0.0 ≤ v < 11.0.3 | 7.1.2, 8.0.8, 9.0.4, 9.1.3, 10.0.10, 11.0.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.