CVE-2021-21370

Medium

Description

TYPO3 is an open source PHP based web content management system. In TYPO3 before versions 7.6.51, 8.7.40, 9.5.25, 10.4.14, 11.1.1 it has been discovered that content elements of type _menu_ are vulnerable to cross-site scripting when their referenced items get previewed in the page module. A valid backend user account is needed to exploit this vulnerability. This is fixed in versions 7.6.51, 8.7.40, 9.5.25, 10.4.14, 11.1.1.

SeverityMedium
CVSS5.4
Exploit probability—
ProductTypo3
PublishedMar 23, 2021
First seenMar 23, 2021

How to fix

Update
  • typo3 typo37.6.51, 8.7.40, 9.5.25, 10.4.14, 11.1.1 or later
  • typo3/cms-backend7.6.51, 8.7.40, 9.5.25, 10.4.14, 11.1.1 or later
  • typo3/cms-core10.4.14, 11.1.1, 9.5.25 or later
  • typo3/cms10.4.14, 11.1.1, 9.5.25 or later

Affected products

ProductAffected versionsFixed in
typo3 typo37.0.0 ≤ v < 7.6.51, 8.0.0 ≤ v < 8.7.40, 9.0.0 ≤ v < 9.5.25, 10.0.0 ≤ v < 10.4.14, 11.0.0 ≤ v < 11.1.17.6.51, 8.7.40, 9.5.25, 10.4.14, 11.1.1
typo3/cms-backendPackagist7.0.0 ≤ v < 7.6.51, 8.0.0 ≤ v < 8.7.40, 9.0.0 ≤ v < 9.5.25, 10.0.0 ≤ v < 10.4.14, 11.0.0 ≤ v < 11.1.17.6.51, 8.7.40, 9.5.25, 10.4.14, 11.1.1
typo3/cms-corePackagist10.0.0 ≤ v < 10.4.14, 11.0.0 ≤ v < 11.1.1, 9.0.0 ≤ v < 9.5.2510.4.14, 11.1.1, 9.5.25
typo3/cmsPackagist10.0.0 ≤ v < 10.4.14, 11.0.0 ≤ v < 11.1.1, 9.0.0 ≤ v < 9.5.2510.4.14, 11.1.1, 9.5.25

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.