CVE-2021-21389

High

Description

BuddyPress is an open source WordPress plugin to build a community site. In releases of BuddyPress from 5.0.0 before 7.2.1 it's possible for a non-privileged, regular user to obtain administrator rights by exploiting an issue in the REST API members endpoint. The vulnerability has been fixed in BuddyPress 7.2.1. Existing installations of the plugin should be updated to this version to mitigate the issue.

SeverityHigh
CVSS8.1
Exploit probability—
ProductBuddypress
PublishedMar 26, 2021
First seenMar 26, 2021

How to fix

Update
  • buddypress buddypress7.2.1 or later
  • buddypress/buddypress7.2.1 or later

Affected products

ProductAffected versionsFixed in
buddypress buddypress5.0.0 ≤ v < 7.2.17.2.1
buddypress/buddypressPackagist5.0.0 ≤ v < 7.2.17.2.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.