CVE-2021-21501
High
Description
Improper configuration will cause ServiceComb ServiceCenter Directory Traversal problem in ServcieCenter 1.x.x versions and fixed in 2.0.0.
SeverityHigh
CVSS7.5
Exploit probability—
Product
Apache Servicecomb
PublishedAug 10, 2021
First seenAug 10, 2021
Weakness typeCWE-22Path traversal
How to fix
Update
- apache servicecomb2.0.0 or later
- github.com/apache/servicecomb-service-center2.0.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache servicecomb | 1.0.0 ≤ v < 2.0.0 | 2.0.0 |
| github.com/apache/servicecomb-service-centerGo | v < 2.0.0 | 2.0.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.