CVE-2021-22051
Medium
Description
Applications using Spring Cloud Gateway are vulnerable to specifically crafted requests that could make an extra request on downstream services. Users of affected versions should apply the following mitigation: 3.0.x users should upgrade to 3.0.5+, 2.2.x users should upgrade to 2.2.10.RELEASE or newer.
SeverityMedium
CVSS6.5
Exploit probability—
Product
Vmware Spring Cloud Gateway
PublishedNov 8, 2021
First seenNov 8, 2021
How to fix
Update
- vmware spring_cloud_gateway2.2.10, 3.0.5 or later
- org.springframework.cloud:spring-cloud-gateway3.0.5, 2.2.10.RELEASE0.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| vmware spring_cloud_gateway | v < 2.2.10, 3.0.0 ≤ v < 3.0.5 | 2.2.10, 3.0.5 |
| org.springframework.cloud:spring-cloud-gatewayMaven | 3.0.0 ≤ v < 3.0.5, 2.2.0 ≤ v < 2.2.10.RELEASE0.5 | 3.0.5, 2.2.10.RELEASE0.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.