CVE-2021-22565

Medium

Description

An attacker could prematurely expire a verification code, making it unusable by the patient, making the patient unable to upload their TEKs to generate exposure notifications. We recommend upgrading the Exposure Notification server to V1.1.2 or greater.

SeverityMedium
CVSS6.5
Exploit probability—
ProductGoogle Exposure Notification Verification Server
PublishedDec 9, 2021
First seenDec 9, 2021

How to fix

Update
  • google exposure_notification_verification_server1.1.2 or later
  • github.com/google/exposure-notifications-verification-server1.1.2 or later

Affected products

ProductAffected versionsFixed in
google exposure_notification_verification_serverv < 1.1.21.1.2
github.com/google/exposure-notifications-verification-serverGov < 1.1.21.1.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.