CVE-2021-22864

High

Description

A remote code execution vulnerability was identified in GitHub Enterprise Server that could be exploited when building a GitHub Pages site. User-controlled configuration options used by GitHub Pages were not sufficiently restricted and made it possible to override environment variables leading to code execution on the GitHub Enterprise Server instance. To exploit this vulnerability, an attacker would need permission to create and build a GitHub Pages site on the GitHub Enterprise Server instance. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.0.3 and was fixed in 3.0.3, 2.22.9, and 2.21.17. This vulnerability was reported via the GitHub Bug Bounty program.

SeverityHigh
CVSS8.8
Exploit probability85. percentile2.6%
ProductGithub Enterprise Server
PublishedMar 23, 2021
First seenMar 23, 2021

How to fix

Update
  • github enterprise_server2.21.17, 2.22.9, 3.0.3 or later

Affected products

ProductAffected versionsFixed in
github enterprise_server2.21.0 ≤ v < 2.21.17, 2.22.0 ≤ v < 2.22.9, 3.0.0 ≤ v < 3.0.32.21.17, 2.22.9, 3.0.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.