CVE-2021-25642
Description
ZKConfigurationStore which is optionally used by CapacityScheduler of Apache Hadoop YARN deserializes data obtained from ZooKeeper without validation. An attacker having access to ZooKeeper can run arbitrary commands as YARN user by exploiting this. Users should upgrade to Apache Hadoop 2.10.2, 3.2.4, 3.3.4 or later (containing YARN-11126) if ZKConfigurationStore is used.
How to fix
- apache hadoop2.10.2, 3.2.4, 3.3.4 or later
- org.apache.hadoop:hadoop-yarn-server2.10.2, 3.2.4, 3.3.4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache hadoop | 2.9.0 ≤ v < 2.10.2, 3.0.0 ≤ v < 3.2.4, 3.3.0 ≤ v < 3.3.4 | 2.10.2, 3.2.4, 3.3.4 |
| org.apache.hadoop:hadoop-yarn-serverMaven | v < 2.10.2, 3.0.0 ≤ v < 3.2.4, 3.3.0 ≤ v < 3.3.4 | 2.10.2, 3.2.4, 3.3.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.