CVE-2021-26543
High
Description
The "gitDiff" function in Wayfair git-parse <=1.0.4 has a command injection vulnerability. Clients of the git-parse library are unlikely to be aware of this, so they might unwittingly write code that contains a vulnerability. The issue has been resolved in version 1.0.5.
SeverityHigh
CVSS8.8
Exploit probability—
ProductWayfair Git-parse
PublishedMay 6, 2021
First seenMay 6, 2021
How to fix
Update
- wayfair git-parse1.0.5 or later
- git-parse1.0.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| wayfair git-parse | v < 1.0.5 | 1.0.5 |
| git-parsenpm | v < 1.0.5 | 1.0.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.