CVE-2021-26813

High

Description

markdown2 >=1.0.1.18, fixed in 2.4.0, is affected by a regular expression denial of service vulnerability. If an attacker provides a malicious string, it can make markdown2 processing difficult or delayed for an extended period of time.

SeverityHigh
CVSS7.5
Exploit probability—
ProductMarkdown2
PublishedMar 3, 2021
First seenMar 3, 2021

How to fix

Affected products

ProductAffected versionsFixed in
markdown2_project markdown21.0.1.18 ≤ v < 2.4.02.4.0
fedoraproject fedora32, 33, 34—
markdown2PyPI1.0.1.18 ≤ v < 2.4.02.4.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.