CVE-2021-29438

Medium

Description

The Nextcloud dialogs library (npm package @nextcloud/dialogs) before 3.1.2 insufficiently escaped text input passed to a toast. If your application displays toasts with user-supplied input, this could lead to a XSS vulnerability. The vulnerability has been patched in version 3.1.2 If you need to display HTML in the toast, explicitly pass the `options.isHTML` config flag.

SeverityMedium
CVSS4.6
Exploit probability—
Product@nextcloud/dialogs
PublishedApr 13, 2021
First seenApr 13, 2021

How to fix

Update
  • @nextcloud/dialogs3.1.2 or later
  • nextcloud\/dialogs_project nextcloud\/dialogs3.1.2 or later

Affected products

ProductAffected versionsFixed in
@nextcloud/dialogsnpmv < 3.1.23.1.2
nextcloud\/dialogs_project nextcloud\/dialogsv < 3.1.23.1.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.