CVE-2021-29506
Medium
Description
GraphHopper is an open-source Java routing engine. In GrassHopper from version 2.0 and before version 2.4, there is a regular expression injection vulnerability that may lead to Denial of Service. This has been patched in 2.4 and 3.0 See this pull request for the fix: https://github.com/graphhopper/graphhopper/pull/2304
SeverityMedium
CVSS6.5
Exploit probability—
ProductGraphhopper
PublishedMay 13, 2021
First seenMay 13, 2021
Weakness typeCWE-400Uncontrolled resource consumption
How to fix
Update
- graphhopper graphhopper2.4 or later
- com.graphhopper:graphhopper-nav2.4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| graphhopper graphhopper | 2.0 ≤ v < 2.4 | 2.4 |
| com.graphhopper:graphhopper-navMaven | v < 2.4 | 2.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.