CVE-2021-29625
Description
Adminer is open-source database management software. A cross-site scripting vulnerability in Adminer versions 4.6.1 to 4.8.0 affects users of MySQL, MariaDB, PgSQL and SQLite. XSS is in most cases prevented by strict CSP in all modern browsers. The only exception is when Adminer is using a `pdo_` extension to communicate with the database (it is used if the native extensions are not enabled). In browsers without CSP, Adminer versions 4.6.1 to 4.8.0 are affected. The vulnerability is patched in version 4.8.1. As workarounds, one can use a browser supporting strict CSP or enable the native PHP extensions (e.g. `mysqli`) or disable displaying PHP errors (`display_errors`).
How to fix
- adminer adminer4.8.1 or later
- vrana/adminer4.8.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| adminer adminer | 4.6.1 ≤ v < 4.8.1 | 4.8.1 |
| vrana/adminerPackagist | 4.7.8 ≤ v < 4.8.1 | 4.8.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.