CVE-2021-32641

High

Description

auth0-lock is Auth0's signin solution. Versions of nauth0-lock before and including `11.30.0` are vulnerable to reflected XSS. An attacker can execute arbitrary code when the library's `flashMessage` feature is utilized and user input or data from URL parameters is incorporated into the `flashMessage` or the library's `languageDictionary` feature is utilized and user input or data from URL parameters is incorporated into the `languageDictionary`. The vulnerability is patched in version 11.30.1.

SeverityHigh
CVSS8.1
Exploit probability—
ProductAuth0 Lock
PublishedJun 4, 2021
First seenJun 4, 2021

How to fix

Update
  • auth0 lock11.30.1 or later
  • auth0-lock11.30.1 or later

Affected products

ProductAffected versionsFixed in
auth0 lockv < 11.30.111.30.1
auth0-locknpmv < 11.30.111.30.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.