CVE-2021-32687
Description
Redis is an open source, in-memory database that persists on disk. An integer overflow bug affecting all versions of Redis can be exploited to corrupt the heap and potentially be used to leak arbitrary contents of the heap or trigger remote code execution. The vulnerability involves changing the default set-max-intset-entries configuration parameter to a very large value and constructing specially crafted commands to manipulate sets. The problem is fixed in Redis versions 6.2.6, 6.0.16 and 5.0.14. An additional workaround to mitigate the problem without patching the redis-server executable is to prevent users from modifying the set-max-intset-entries configuration parameter. This can be done using ACL to restrict unprivileged users from using the CONFIG SET command.
How to fix
- redis redis5.0.14, 6.0.16, 6.2.6 or later
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VL5KXFN3ATM7IIM7Q4O4PWTSRGZ5744Z/
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HTYQ5ZF37HNGTZWVNJD3VXP7I6MEEF42/
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WR5WKJWXD4D6S3DJCZ56V74ESLTDQRAB/
- debian.org/security/2021/dsa-5001
- security.gentoo.org/glsa/202209-17
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| redis redis | 5.0.0 ≤ v < 5.0.14, 6.0.0 ≤ v < 6.0.16, 6.2.0 ≤ v < 6.2.6 | 5.0.14, 6.0.16, 6.2.6 |
| fedoraproject fedora | 33, 34, 35 | — |
| debian debian_linux | 10.0, 11.0 | — |
| netapp management_services_for_element_software | No range specified | — |
| netapp management_services_for_netapp_hci | No range specified | — |
| oracle communications_operations_monitor | 4.3, 4.4, 5.0 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.