CVE-2021-32702
Description
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions before and including `1.4.1` are vulnerable to reflected XSS. An attacker can execute arbitrary code by providing an XSS payload in the `error` query parameter which is then processed by the callback handler as an error message. You are affected by this vulnerability if you are using `@auth0/nextjs-auth0` version `1.4.1` or lower **unless** you are using custom error handling that does not return the error message in an HTML response. Upgrade to version `1.4.1` to resolve. The fix adds basic HTML escaping to the error message and it should not impact your users.
How to fix
- auth0 nextjs-auth01.4.2 or later
- @auth0/nextjs-auth01.4.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| auth0 nextjs-auth0 | v < 1.4.2 | 1.4.2 |
| @auth0/nextjs-auth0npm | v < 1.4.2 | 1.4.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.