CVE-2021-32716
Description
Shopware is an open source eCommerce platform. In versions prior to 6.4.1.1 the admin api has exposed some internal hidden fields when an association has been loaded with a to many reference. Users are recommend to update to version 6.4.1.1. You can get the update to 6.4.1.1 regularly via the Auto-Updater or directly via the download overview. For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin.
How to fix
- shopware shopware6.4.1.1 or later
- shopware/platform6.4.1.1 or later
- shopware/core6.4.1.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| shopware shopware | 6.1.0 ≤ v < 6.4.1.1 | 6.4.1.1 |
| shopware/platformPackagist | v < 6.4.1.1 | 6.4.1.1 |
| shopware/corePackagist | v < 6.4.1.1 | 6.4.1.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.