CVE-2021-32782
Description
Nextcloud Circles is an open source social network built for the nextcloud ecosystem. In affected versions the Nextcloud Circles application is vulnerable to a stored Cross-Site Scripting (XSS) vulnerability. Due the strict Content-Security-Policy shipped with Nextcloud, this issue is not exploitable on modern browsers supporting Content-Security-Policy. It is recommended that the Nextcloud Circles application is upgraded to 0.21.3, 0.20.10 or 0.19.14 to resolve this issue. As a workaround users may use a browser that has support for Content-Security-Policy. A notable exemption is Internet Explorer which does not support CSP properly.
How to fix
- nextcloud circles0.19.14, 0.20.10, 0.21.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| nextcloud circles | v < 0.19.14, 0.20.0 ≤ v < 0.20.10, 0.21.0 ≤ v < 0.21.3 | 0.19.14, 0.20.10, 0.21.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.