CVE-2021-32801
Description
Nextcloud server is an open source, self hosted personal cloud. In affected versions logging of exceptions may have resulted in logging potentially sensitive key material for the Nextcloud Encryption-at-Rest functionality. It is recommended that the Nextcloud Server is upgraded to 20.0.12, 21.0.4 or 22.1.0. If upgrading is not an option users are advised to disable system logging to resolve this issue until such time that an upgrade can be performed Note that ff you do not use the Encryption-at-Rest functionality of Nextcloud you are not affected by this bug.
How to fix
- nextcloud nextcloud_server20.0.12, 21.0.4, 22.1.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| nextcloud nextcloud_server | v < 20.0.12, 21.0.0 ≤ v < 21.0.4, 22.0.0 ≤ v < 22.1.0 | 20.0.12, 21.0.4, 22.1.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.