CVE-2021-32814

High

Description

Skytable is a NoSQL database with automated snapshots and TLS. Versions prior to 0.5.1 are vulnerable to a a directory traversal attack enabling remotely connected clients to destroy and/or manipulate critical files on the host's file system. This security bug has been patched in version 0.5.1. There are no known workarounds aside from upgrading.

SeverityHigh
CVSS8.8
Exploit probability—
ProductSkytable
PublishedAug 3, 2021
First seenAug 3, 2021

How to fix

Update
  • skytable skytable0.5.1 or later

Affected products

ProductAffected versionsFixed in
skytable skytablev < 0.5.10.5.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.