CVE-2021-3377

Medium

Description

The npm package ansi_up converts ANSI escape codes into HTML. In ansi_up v4, ANSI escape codes can be used to create HTML hyperlinks. Due to insufficient URL sanitization, this feature is affected by a cross-site scripting (XSS) vulnerability. This issue is fixed in v5.0.0.

SeverityMedium
CVSS6.1
Exploit probability—
ProductAnsi Up
PublishedMar 5, 2021
First seenMar 5, 2021

How to fix

Update
  • ansi_up_project ansi_up5.0.0 or later
  • ansi_up5.0.0 or later

Affected products

ProductAffected versionsFixed in
ansi_up_project ansi_upv < 5.0.05.0.0
ansi_upnpmv < 5.0.05.0.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.